#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#\[\[(?<name>.+?)\]\]"
Local $sString = "my first name is #[[1:hashTag:Rameez]] and second name is  #[[2:hashTag:Rameez2]]." & @CRLF & _
                "Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")