package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\[\[(?<name>.+?)\]\]`)
var str = `my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}