import re
regex = re.compile(r"#\[\[(?<name>.+?)\]\]")
test_str = ("my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].\n"
"Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")