// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#\[\[(?<name>.+?)\]\]").unwrap();
let string = "my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}