#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+"
Local $sString = "aaaaaa eeiou 00uydddddsy"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)