$re = '/([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+/m';
$str = 'aaaaaa eeiou 00uydddddsy';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;