using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+";
string substitution = @"$1";
string input = @"aaaaaa eeiou 00uydddddsy";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}