import Foundation
let pattern = #"([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaaaaa eeiou 00uydddddsy"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)