re = /([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+/m
str = 'aaaaaa eeiou 00uydddddsy'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result