const regex = /([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aeioucgjkqsxyzbfpvwdtmn1234567890])\\1+', 'gm')
const str = `aaaaaa eeiou 00uydddddsy`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);