use strict;
my $str = 'aaaaaa eeiou 00uydddddsy';
my $regex = qr/([aeioucgjkqsxyzbfpvwdtmn1234567890])\1+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";