# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<!\n)\n{2}(?!\n))|\n+/\1/gi;t' <<< "
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
"