#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)((?<!\n)\n{2}(?!\n))|\n+"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"ashdh hjgsad " & @CRLF & _
" asdsad " & @CRLF & _
"" & @CRLF & _
" asdasd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"asdsadsa" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sas" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"as" & @CRLF & _
"" & @CRLF & _
"asfsads" & @CRLF & _
"" & @CRLF & _
"2here" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)