$re = '/((?<!\n)\n{2}(?!\n))|\n+/i';
$str = '
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;