re = /((?<!\n)\n{2}(?!\n))|\n+/i
str = '
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result