# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\[[^|\n]*(?:\|[^|\n]*){2,}\]$/\1/gm;t' <<< "[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]"