package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^|\n]*(?:\|[^|\n]*){2,}\]$`)
var str = `[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}