using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[[^|\n]*(?:\|[^|\n]*){2,}\]$";
string substitution = @"\1";
string input = @"[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}