#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\[[^|\n]*(?:\|[^|\n]*){2,}\]$"
Local $sString = "[keyword1|keyword2|keyword3]" & @CRLF & _
"[keyword1|keyword2]" & @CRLF & _
"[keyword1|keyword2|keyword3,keyword4]"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)