$re = '/^\[[^|\n]*(?:\|[^|\n]*){2,}\]$/m';
$str = '[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;