re = /^\[[^|\n]*(?:\|[^|\n]*){2,}\]$/m
str = '[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result