const regex = /^\[[^|\n]*(?:\|[^|\n]*){2,}\]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^|\\n]*(?:\\|[^|\\n]*){2,}\\]$', 'gm')
const str = `[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3,keyword4]`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);