#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(-?\d{1,2}\.\d{6,},-?\d{1,2}\.\d{6,}),"
Local $sString = "photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,," & @CRLF & _
"photoname.jpg,53.345533,28.345533,,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")