// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r",(-?\d{1,2}\.\d{6,},-?\d{1,2}\.\d{6,}),").unwrap();
let string = "photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,
photoname.jpg,53.345533,28.345533,,,,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}