import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(-?\\d{1,2}\\.\\d{6,},-?\\d{1,2}\\.\\d{6,}),";
final String string = "photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,\n"
+ "photoname.jpg,53.345533,28.345533,,,,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}