const regex = new RegExp(',(-?\\d{1,2}\\.\\d{6,},-?\\d{1,2}\\.\\d{6,}),', 'g')
const str = `photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,
photoname.jpg,53.345533,28.345533,,,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}