using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(-?\d{1,2}\.\d{6,},-?\d{1,2}\.\d{6,}),";
string input = @"photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,
photoname.jpg,53.345533,28.345533,,,,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}