use strict;
my $str = 'photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,
photoname.jpg,53.345533,28.345533,,,,';
my $regex = qr/,(-?\d{1,2}\.\d{6,},-?\d{1,2}\.\d{6,}),/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}