re = /,(-?\d{1,2}\.\d{6,},-?\d{1,2}\.\d{6,}),/
str = 'photoname.jpg,99.3333,14.44556,53.345533,28.345533,foo,,
photoname.jpg,53.345533,28.345533,,,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end