#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "barcode\?message=(.+)(\n)(.+)""
Local $sString = "<img alt="Barcode for scanning boarding pass" height ="287" width="287" src="/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg" & @CRLF & _
"MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")