import re
regex = re.compile(r"barcode\?message=(.+)(\n)(.+)\"")
test_str = ("<img alt=\"Barcode for scanning boarding pass\" height =\"287\" width=\"287\" src=\"/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg\n"
"MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=\" />\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")