import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "barcode\\?message=(.+)(\\n)(.+)\"";
final String string = "<img alt=\"Barcode for scanning boarding pass\" height =\"287\" width=\"287\" src=\"/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg\n"
+ "MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=\" />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}