re = /barcode\?message=(.+)(\n)(.+)"/
str = '<img alt="Barcode for scanning boarding pass" height ="287" width="287" src="/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg
MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=" />
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end