$re = '/barcode\?message=(.+)(\n)(.+)"/';
$str = '<img alt="Barcode for scanning boarding pass" height ="287" width="287" src="/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg
MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=" />
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);