use strict;
my $str = 'Example';
my $regex = qr/(\w+)/p;
my $subst = '<em>$1</em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";