// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)").unwrap();
let string = "Example";
let substitution = "<em>$1</em>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}