import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w][\\S]{0,8}$";
final String string = "Hello!@+\n"
+ "t123123\n"
+ "H123!#\n"
+ "@adadsa\n"
+ "@3asdasd\n"
+ "%sdf\n"
+ "Helloworld1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}