const regex = /^[\w][\S]{0,8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w][\\S]{0,8}$', 'gm')
const str = `Hello!@+
t123123
H123!#
@adadsa
@3asdasd
%sdf
Helloworld1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}