re = /^[\w][\S]{0,8}$/m
str = 'Hello!@+
t123123
H123!#
@adadsa
@3asdasd
%sdf
Helloworld1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end