$re = '/^[\w][\S]{0,8}$/m';
$str = 'Hello!@+
t123123
H123!#
@adadsa
@3asdasd
%sdf
Helloworld1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);