# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[.,?!'"]+|[.,?!'"]*?(?:'s)?$//gm;t' <<< "'Hello world, josh's car.,'
Hello World.......
..,!Bye World
.???'\"\"\"Again, what message should I type here!!!
....fdsa That car is John's"