import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[.,?!'\"]+|[.,?!'\"]*?(?:'s)?$";
final String string = "'Hello world, josh's car.,'\n\n"
+ "Hello World.......\n"
+ "..,!Bye World\n\n"
+ ".???'\"\"\"Again, what message should I type here!!!\n\n"
+ "....fdsa That car is John's";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}