#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[.,?!'"]+|[.,?!'"]*?(?:'s)?$"
Local $sString = "'Hello world, josh's car.,'" & @CRLF & _
"" & @CRLF & _
"Hello World......." & @CRLF & _
"..,!Bye World" & @CRLF & _
"" & @CRLF & _
".???'"""Again, what message should I type here!!!" & @CRLF & _
"" & @CRLF & _
"....fdsa That car is John's"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)