re = /^[.,?!'"]+|[.,?!'"]*?(?:'s)?$/m
str = '\'Hello world, josh\'s car.,\'
Hello World.......
..,!Bye World
.???\'"""Again, what message should I type here!!!
....fdsa That car is John\'s'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result