use strict;
my $str = '\'Hello world, josh\'s car.,\'
Hello World.......
..,!Bye World
.???\'"""Again, what message should I type here!!!
....fdsa That car is John\'s';
my $regex = qr/^[.,?!'"]+|[.,?!'"]*?(?:'s)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";