# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d[\d\s]*)(?=\s+)/<b>$1<\/b>/g;t' <<< "abc 1 2 3 abc"