import Foundation
let pattern = #"(\d[\d\s]*)(?=\s+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abc 1 2 3 abc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$1</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)