using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d[\d\s]*)(?=\s+)";
string substitution = @"<b>$1</b>";
string input = @"abc 1 2 3 abc";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}