#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d[\d\s]*)(?=\s+)"
Local $sString = "abc 1 2 3 abc"
Local $sSubst = "<b>$1</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)