$re = '/(\d[\d\s]*)(?=\s+)/';
$str = 'abc 1 2 3 abc';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;